Onedrive - Access Denied

Fix OneDrive "Access Denied" by Rebuilding OneDrive Site

Issue

User receives:

  • "Access Denied" when accessing OneDrive while correctly licensed with an E3

  • Error 0x8004e4d0

  • OneDrive URL loads AccessDenied.aspx

Root Cause

OneDrive site identity mismatch / corrupted SharePoint user mapping.

Resolution

Unlicense SharePoint → Delete OneDrive site → Re-license → Reprovision


METHOD 1 — POWERSHELL

Step 1: Install SharePoint Online Module (if not installed)

Open PowerShell as Admin:

Install-Module Microsoft.Online.SharePoint.PowerShell -Scope CurrentUser

Step 2: Connect to SharePoint Online

Connect-SPOService -Url https://usam3-admin.sharepoint.com/

Sign in with admin account.


Step 3: Set variables

$UserUPN = "user@domain.com"
$OneDriveUrl = "https://<tenant>-my.sharepoint.com/personal/user_domain_com"

Example: UPN: breilly@usa.m3.com
         URL: 
https://usam3-my.sharepoint.com/personal/breilly_usa_m3_com


Step 4: Delete OneDrive site

Remove-SPOSite -Identity $OneDriveUrl

Example: Remove-SPOSite -Identity "https://usam3-my.sharepoint.com/personal/breilly_usa_m3_com"


Step 5: Permanently delete from recycle bin

Remove-SPODeletedSite -Identity $OneDriveUrl

Example: Remove-SPODeletedSite -Identity "https://usam3-my.sharepoint.com/personal/breilly_usa_m3_com"


Step 6: Remove SharePoint license (DO THIS IN GUI)

  • Go to Microsoft 365 Admin Center

  • Users → Active Users → Select user

  • Licenses and Apps

  • Uncheck Microsoft E3

  • Save

Wait 10–15 minutes


Step 7: Reassign license

  • Re-check Microsoft E3

  • Save


Step 8: Recreate OneDrive site

Request-SPOPersonalSite -UserEmails $UserUPN

Example: Request-SPOPersonalSite -UserEmails "breilly@usa-m3.com"


Step 9: Wait and test


METHOD 2 — GUI ONLY

Step 1: Remove license

  • Microsoft 365 Admin Center

  • Users → Active Users → Select user

  • Licenses and Apps

  • Uncheck SharePoint Online

  • Save

Wait 10–15 minutes


Step 2: Delete OneDrive site

  • Go to SharePoint Admin Center (Sharepoint Admin Center)

  • Click More features

  • Click User profiles

  • Click Manage User Profiles

  • Search for user

  • Click user → Delete Personal Site

Uploaded Image (Thumbnail)

OR

  • SharePoint Admin Center → Active Sites

  • Filter: OneDrive

  • Find user site

  • Select → Delete


Step 3: Remove from Deleted Sites

  • SharePoint Admin Center → Deleted Sites

  • Find user OneDrive

  • Select → Delete permanently


Step 4: Reassign license

  • Go back to user

  • Re-enable SharePoint Online

  • Save


Step 5: Trigger OneDrive creation

User goes to:
https://portal.office.com → OneDrive

 

Notes

  • This will delete existing OneDrive data unless recovered beforehand

  • Use this when:

    • AccessDenied.aspx appears

    • Owner is correct but access fails

    • Sign-in logs show success


Summary

If OneDrive shows Access Denied but everything else looks correct:

Rebuild the OneDrive site.